can not install glibc-devel ‘Requires: libnss_files.so.2’ error

Posted on

can not install glibc-devel ‘Requires: libnss_files.so.2’ error – Managing your servers can streamline the performance of your team by allowing them to complete complex tasks faster. Plus, it can enable them to detect problems early on before they get out of hand and compromise your business. As a result, the risk of experiencing operational setbacks is drastically lower.

But the only way to make the most of your server management is to perform it correctly. And to help you do so, this article will share nine tips on improving your server management and fix some problem about linux, rpm, glibc, , .

I’m using Linux 6.1
I need to install glibc-devel but it fails with this error.

[root@server1 Packages]# yum install glibc-devel-2.12-1.25.el6.i686.rpm
Loaded plugins: refresh-packagekit
Setting up Install Process
Examining glibc-devel-2.12-1.25.el6.i686.rpm: glibc-devel-2.12-1.25.el6.i686
Marking glibc-devel-2.12-1.25.el6.i686.rpm to be installed
Resolving Dependencies
--> Running transaction check
---> Package glibc-devel.i686 0:2.12-1.25.el6 will be installed
--> Processing Dependency: libBrokenLocale.so.1 for package: glibc-devel-2.12-1.25.el6.i686
--> Processing Dependency: libanl.so.1 for package: glibc-devel-2.12-1.25.el6.i686
--> Processing Dependency: libcidn.so.1 for package: glibc-devel-2.12-1.25.el6.i686
--> Processing Dependency: libcrypt.so.1 for package: glibc-devel-2.12-1.25.el6.i686
--> Processing Dependency: libdl.so.2 for package: glibc-devel-2.12-1.25.el6.i686
--> Processing Dependency: libm.so.6 for package: glibc-devel-2.12-1.25.el6.i686
--> Processing Dependency: libnsl.so.1 for package: glibc-devel-2.12-1.25.el6.i686
--> Processing Dependency: libnss_compat.so.2 for package: glibc-devel-2.12-1.25.el6.i686
--> Processing Dependency: libnss_dns.so.2 for package: glibc-devel-2.12-1.25.el6.i686
--> Processing Dependency: libnss_files.so.2 for package: glibc-devel-2.12-1.25.el6.i686
--> Processing Dependency: libnss_hesiod.so.2 for package: glibc-devel-2.12-1.25.el6.i686
--> Processing Dependency: libnss_nis.so.2 for package: glibc-devel-2.12-1.25.el6.i686
--> Processing Dependency: libnss_nisplus.so.2 for package: glibc-devel-2.12-1.25.el6.i686
--> Processing Dependency: libresolv.so.2 for package: glibc-devel-2.12-1.25.el6.i686
--> Processing Dependency: librt.so.1 for package: glibc-devel-2.12-1.25.el6.i686
--> Processing Dependency: libthread_db.so.1 for package: glibc-devel-2.12-1.25.el6.i686
--> Processing Dependency: libutil.so.1 for package: glibc-devel-2.12-1.25.el6.i686
--> Finished Dependency Resolution
Error: Package: glibc-devel-2.12-1.25.el6.i686 (/glibc-devel-2.12-1.25.el6.i686)
           Requires: libnss_files.so.2
Error: Package: glibc-devel-2.12-1.25.el6.i686 (/glibc-devel-2.12-1.25.el6.i686)
           Requires: libutil.so.1
Error: Package: glibc-devel-2.12-1.25.el6.i686 (/glibc-devel-2.12-1.25.el6.i686)
           Requires: libnss_dns.so.2
Error: Package: glibc-devel-2.12-1.25.el6.i686 (/glibc-devel-2.12-1.25.el6.i686)
           Requires: libnss_compat.so.2
Error: Package: glibc-devel-2.12-1.25.el6.i686 (/glibc-devel-2.12-1.25.el6.i686)
           Requires: libanl.so.1
Error: Package: glibc-devel-2.12-1.25.el6.i686 (/glibc-devel-2.12-1.25.el6.i686)
           Requires: librt.so.1
Error: Package: glibc-devel-2.12-1.25.el6.i686 (/glibc-devel-2.12-1.25.el6.i686)
           Requires: libthread_db.so.1
Error: Package: glibc-devel-2.12-1.25.el6.i686 (/glibc-devel-2.12-1.25.el6.i686)
           Requires: libm.so.6
Error: Package: glibc-devel-2.12-1.25.el6.i686 (/glibc-devel-2.12-1.25.el6.i686)
           Requires: libnss_nis.so.2
Error: Package: glibc-devel-2.12-1.25.el6.i686 (/glibc-devel-2.12-1.25.el6.i686)
           Requires: libnsl.so.1
Error: Package: glibc-devel-2.12-1.25.el6.i686 (/glibc-devel-2.12-1.25.el6.i686)
           Requires: libnss_nisplus.so.2
Error: Package: glibc-devel-2.12-1.25.el6.i686 (/glibc-devel-2.12-1.25.el6.i686)
           Requires: libnss_hesiod.so.2
Error: Package: glibc-devel-2.12-1.25.el6.i686 (/glibc-devel-2.12-1.25.el6.i686)
           Requires: libcrypt.so.1
Error: Package: glibc-devel-2.12-1.25.el6.i686 (/glibc-devel-2.12-1.25.el6.i686)
           Requires: libresolv.so.2
Error: Package: glibc-devel-2.12-1.25.el6.i686 (/glibc-devel-2.12-1.25.el6.i686)
           Requires: libdl.so.2
Error: Package: glibc-devel-2.12-1.25.el6.i686 (/glibc-devel-2.12-1.25.el6.i686)
           Requires: libcidn.so.1
Error: Package: glibc-devel-2.12-1.25.el6.i686 (/glibc-devel-2.12-1.25.el6.i686)
           Requires: libBrokenLocale.so.1
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest  

Solution :

I resovled this issue by installing glibc-2.12-1.25.el6.i686.rpm first.

But when installing ‘glibc-2.12-1.25.el6.i686.rpm’ I got this error.
Error: Package: glibc-2.12-1.25.el6.i686 (/glibc-2.12-1.25.el6.i686)
Requires: libfreebl3.so(NSSRAWHASH_3.12.3)
Error: Package: glibc-2.12-1.25.el6.i686 (/glibc-2.12-1.25.el6.i686)
Requires: libfreebl3.so

I resolved this ‘libfreebl3.so’ error by installing nss-softokn-freebl-3.12.9-3.el6.i686.rpm glibc-2.12-1.25.el6.i686.rpm at the same time. <= this is the point of the solution !!!

$ yum install nss-softokn-freebl-3.12.9-3.el6.i686.rpm glibc-2.12-1.25.el6.i686.rpm

After this I could install ‘glibc-devel-2.12-1.25.el6.i686.rpm’ successfully.
$ yum install glibc-devel-2.12-1.25.el6.i686.rpm

Leave a Reply

Your email address will not be published. Required fields are marked *