One of my websites stopped working without apparent reason. Help me figure out why? [closed]

Posted on

One of my websites stopped working without apparent reason. Help me figure out why? [closed] – Managing your servers can streamline the performance of your team by allowing them to complete complex tasks faster. Plus, it can enable them to detect problems early on before they get out of hand and compromise your business. As a result, the risk of experiencing operational setbacks is drastically lower.

But the only way to make the most of your server management is to perform it correctly. And to help you do so, this article will share nine tips on improving your server management and fix some problem about linux, apache-2.2, domain-name-system, vps, django.

Hello I’m running unmanaged VPS at Hetzner with Ubuntu Linux. I use Apache to serve webpages and I have 8 websites on it. One particular website stopped responding without reason. Nobody touched anything on that VPS two days ago and it just stopped responding. The website is Django application with similar functionality as StackExchange (OSQA) and I use mod_wsgi to start this Django via apache. Apache logs don’t show anything unusual and I suspect it is a DNS problem. When I try to ping the domain from the VPS I get the right IP:

root@genije:~# ping genije.org
PING genije.org (78.47.124.185) 56(84) bytes of data.
64 bytes from genije.org (78.47.124.185): icmp_req=1 ttl=64 time=0.024 ms
64 bytes from genije.org (78.47.124.185): icmp_req=2 ttl=64 time=0.026 ms

But when I try to use w3m browser from VPS to GET the site I get “can’t load genije.org”. If I try to ping it from my home machine I get different IP:

C:UsersGoran>ping www.genije.org

Pinging www.genije.org [67.215.66.132] with 32 bytes of data:
Request timed out.

So this is why I believe it is a DNS problem. I use Namecheap for domain management with custom DNS servers. They were ns1.genije.org and ns2.genije.org. I just changed them to other ns1.itn.me and ns2.itn.me. Both of those servers point to the same IP. It is a mystery to me why this happen all of the sudden. Here’s my DNS records file from VPS:

$ttl 38400
genije.org. IN  SOA ns1.itn.me. goran.itn.me. (
            1303520547
            10800
            3600
            604800
            38400 )
genije.org. IN  A   78.47.124.185
www.genije.org. IN  A   78.47.124.185
genije.org. IN  MX  5 ALT1.ASPMX.L.GOOGLE.COM.
genije.org. IN  MX  5 ALT2.ASPMX.L.GOOGLE.COM.
genije.org. IN  MX  10 ASPMX2.GOOGLEMAIL.COM.
genije.org. IN  MX  10 ASPMX3.GOOGLEMAIL.COM.
genije.org. IN  NS  ns1.genije.org.
genije.org. IN  NS  ns2.genije.org.
genije.org. IN  MX  1 ASPMX.L.GOOGLE.COM.
mail._domainkey IN TXT "v=DKIM1; g=*; k=rsa; t=y; p=STRINGGGG" ; ----- DKIM mail for genije.org
genije.org. IN  TXT v=spf1 a ptr ip4:78.47.124.185 mx:alt1.aspmx.l.google.com mx:alt2.aspmx.l.google.com mx:aspmx.l.google.com mx:aspmx2.googlemail.com mx:aspmx3.googlemail.com ?all
genije.org. IN  NS  genije.org.
genije.org. IN  NS  ns1.itn.me.

I just added last two NS lines in order to resolve the problem. Can anyone help me find the problem? Maybe my DNS suspicion is wrong, if so can you please point me in the right direction. I never had any similar problem so I don’t know how to act. Thanks!

Goran

Solution :

Both www.genije.org & genije.org work fine. You should probably wait for the DNS to propagate.

Leave a Reply

Your email address will not be published. Required fields are marked *