SVN with WebDAV stopped working after Apache upgrade

Posted on

SVN with WebDAV stopped working after Apache upgrade – Managing your servers can streamline the performance of your team by allowing them to complete complex tasks faster. Plus, it can enable them to detect problems early on before they get out of hand and compromise your business. As a result, the risk of experiencing operational setbacks is drastically lower.

But the only way to make the most of your server management is to perform it correctly. And to help you do so, this article will share nine tips on improving your server management and fix some problem about apache-2.2, svn, webdav, , .

I have just upgraded my Ubuntu 12 server to php 5.5.7 which in turn automatically upgraded my installation of Apache to 2.4.6. After the upgrade my previous installation of SVN running with WebDAV has now stopped working.

When I try installing subversion and libapache2-svn I get the following:

root@Svr01:/# apt-get install subversion libapache2-svn
Reading package lists... Done
Building dependency tree
Reading state information... Done
subversion is already the newest version.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  libapache2-svn : Depends: apache2.2-common but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

“The following packages have unmet dependencies:
libapache2-svn : Depends: apache2.2-common but it is not going to be installed”

I am assuming this means that SVN simply does not work with Apache 2.4.6 yet?

Does anyone know a way around this?

Solution :

Apache modules need to be built at least for the minor version of Apache they are running under. You’re using a binary module that was built for 2.2.x. You’ll need to use 2.2.x, build your own copy of Subversion or find another binary package that is built against 2.4.x.

Leave a Reply

Your email address will not be published.