Unable to install Kerberos libriaries using $ rpm -ivf krb5-libs-1.8.4-3.fc14.x86_64.rpm

Posted on

Unable to install Kerberos libriaries using $ rpm -ivf krb5-libs-1.8.4-3.fc14.x86_64.rpm – Managing your servers can streamline the performance of your team by allowing them to complete complex tasks faster. Plus, it can enable them to detect problems early on before they get out of hand and compromise your business. As a result, the risk of experiencing operational setbacks is drastically lower.

But the only way to make the most of your server management is to perform it correctly. And to help you do so, this article will share nine tips on improving your server management and fix some problem about linux, yum, kerberos, rpm, .

My Linux version is as follows:Red Hat Enterprise Linux Server release 5.5 (Tikanga)
My rpm version is

when I am trying ti run uname -a ,the output i sas follows:

Linux ca1vmprdpsoft1.kla-tencor.com 2.6.18-194.el5 #1 SMP Tue Mar 16 21:52:39 EDT 2010 x86_64 x86_64 x86_64 GNU/Linux

I have downloaded krb5-libs-1.8.4-3.fc14.x86_64.rpm from http://rpmfind.net/linux/rpm2html/search.php?query=krb5-libs .

$ rpm -ivf krb5-libs-1.8.4-3.fc14.x86_64.rpm
warning: krb5-libs-1.8.4-3.fc14.x86_64.rpm: Header V4 DSA signature: NOKEY, key                                                                                                  ID 42d68235
error: Failed dependencies:
        libc.so.6(GLIBC_2.7)(64bit) is needed by krb5-libs-1.8.4-3.fc14.x86_64
        rpmlib(FileDigests) <= 4.6.0-1 is needed by krb5-libs-1.8.4-3.fc14.x86_6                                                                                                 4
        rpmlib(PayloadIsXz) <= 5.2-1 is needed by krb5-libs-1.8.4-3.fc14.x86_64

Please let me know which version of Keberos library should I download so that this error would be resolved or any other suggestion to resolve this issues.

Solution :

Ah, RPM Dependency management.. Or lack of.

You’d be better to configure yum to look at EPEL repositories, then use yum to install what you want, rather than using rpm.

Also, it looks like that version of krb5 requires a more recent version of glibc than you’ve got. This kinda upgrade tends to happen when you’re looking at a version of a package that’s a lot more recent than the current version for your RHEL build.

You’re also trying to install packages from Fedora Core 14 onto a RHEL 5.5 system.
Are there not any vendor supported kerberos libraries? I mean, you’re paying a shitload for support, you might as well use it.

Good luck getting it working without breaking the existing system.

But yeah.. You should be using yum, really.

Leave a Reply

Your email address will not be published.