Whats the bare minimum modules required by Apache to run Drupal

Posted on

Whats the bare minimum modules required by Apache to run Drupal – Managing your servers can streamline the performance of your team by allowing them to complete complex tasks faster. Plus, it can enable them to detect problems early on before they get out of hand and compromise your business. As a result, the risk of experiencing operational setbacks is drastically lower.

But the only way to make the most of your server management is to perform it correctly. And to help you do so, this article will share nine tips on improving your server management and fix some problem about apache-2.2, drupal7, , , .

As part of improving performance of my website I am reducing the memory footprint of Apache. Currently I have the following modules enabled

lrwxrwxrwx 1 root root   28 Aug 31  2012 alias.conf -> ../mods-available/alias.conf
lrwxrwxrwx 1 root root   28 Aug 31  2012 alias.load -> ../mods-available/alias.load
lrwxrwxrwx 1 root root   33 Aug 31  2012 auth_basic.load -> ../mods-available/auth_basic.load
lrwxrwxrwx 1 root root   33 Aug 31  2012 authn_file.load -> ../mods-available/authn_file.load
lrwxrwxrwx 1 root root   36 Aug 31  2012 authz_default.load -> ../mods-available/authz_default.load
lrwxrwxrwx 1 root root   38 Aug 31  2012 authz_groupfile.load -> ../mods-available/authz_groupfile.load
lrwxrwxrwx 1 root root   33 Aug 31  2012 authz_host.load -> ../mods-available/authz_host.load
lrwxrwxrwx 1 root root   33 Aug 31  2012 authz_user.load -> ../mods-available/authz_user.load
lrwxrwxrwx 1 root root   32 Aug 31  2012 autoindex.conf -> ../mods-available/autoindex.conf
lrwxrwxrwx 1 root root   32 Aug 31  2012 autoindex.load -> ../mods-available/autoindex.load
lrwxrwxrwx 1 root root   26 Aug 31  2012 cgi.load -> ../mods-available/cgi.load
lrwxrwxrwx 1 root root   30 Aug 31  2012 deflate.conf -> ../mods-available/deflate.conf
lrwxrwxrwx 1 root root   30 Aug 31  2012 deflate.load -> ../mods-available/deflate.load
lrwxrwxrwx 1 root root   26 Aug 31  2012 dir.conf -> ../mods-available/dir.conf
lrwxrwxrwx 1 root root   26 Aug 31  2012 dir.load -> ../mods-available/dir.load
lrwxrwxrwx 1 root root   26 Aug 31  2012 env.load -> ../mods-available/env.load
lrwxrwxrwx 1 root root   30 Aug 31  2012 headers.load -> ../mods-available/headers.load
lrwxrwxrwx 1 root root   27 Aug 31  2012 mime.conf -> ../mods-available/mime.conf
lrwxrwxrwx 1 root root   27 Aug 31  2012 mime.load -> ../mods-available/mime.load
lrwxrwxrwx 1 root root   34 Aug 31  2012 negotiation.conf -> ../mods-available/negotiation.conf
lrwxrwxrwx 1 root root   34 Aug 31  2012 negotiation.load -> ../mods-available/negotiation.load
lrwxrwxrwx 1 root root   27 Aug 31  2012 php5.conf -> ../mods-available/php5.conf
lrwxrwxrwx 1 root root   27 Aug 31  2012 php5.load -> ../mods-available/php5.load
lrwxrwxrwx 1 root root   33 Aug 31  2012 reqtimeout.conf -> ../mods-available/reqtimeout.conf
lrwxrwxrwx 1 root root   33 Aug 31  2012 reqtimeout.load -> ../mods-available/reqtimeout.load
lrwxrwxrwx 1 root root   30 Aug 31  2012 rewrite.load -> ../mods-available/rewrite.load
lrwxrwxrwx 1 root root   31 Aug 31  2012 setenvif.conf -> ../mods-available/setenvif.conf
lrwxrwxrwx 1 root root   31 Aug 31  2012 setenvif.load -> ../mods-available/setenvif.load
lrwxrwxrwx 1 root root   29 Aug 31  2012 status.conf -> ../mods-available/status.conf
lrwxrwxrwx 1 root root   29 Aug 31  2012 status.load -> ../mods-available/status.load

I would like Apache to load only modules required to run Drupal 7. I don’t intend to use content negotiation so I can disable it. Are there any other modules that I can disable in the above list.

Solution :

I think it is not such important thing to disable these modules.

But if you really want to, you probably can disable all auth* modules as there is “form based” authentication as default in Drupal, which does not need any support from these modules.

Status is not needed if you do not want “server-status” page.

You do not need mod_cgi if your PHP works as Apache module.

I don’t think Drupal makes use of directory listings, so you probably do not need mod_autoindex either.

Leave a Reply

Your email address will not be published.